I have windows 7 64bit and there's a problem with wifi icon as show in attached

Photo...

even if wifi is connected to network it's still showing another icon(i.e not connected icon).

Thanks in advance.

  • 1
    That icon is the icon for a LAN cable. Indeed, it should show you the wifi icon instead. What happens if you plugin a LAN cable? Does the icon then change? And what if you unplug it? Also, have you tried reinstalling both LAN and WiFi drivers? – LPChip Nov 7 at 9:51
  • if i connect cable its the same nothing changed it's always showing the wrong icon – Warlock Nov 7 at 11:49
  • Have you tried reinstalling both drivers for LAN and WiFi? – LPChip Nov 7 at 12:26
  • Try to disable the network adapters and re-enable again. And check the service Wi-fi Direct Services Connection Manager Service. – OOOO Nov 8 at 6:24
  • @LPChip i reinstalled the drivers and it's working now :) ..... Thank for the comment – Warlock Nov 8 at 9:44
up vote 0 down vote accepted

That icon is the icon for a LAN cable. Indeed, it should show you the wifi icon instead.

What happens if you plugin a LAN cable? Does the icon then change? And what if you unplug it?

if i connect cable its the same nothing changed it's always showing the wrong icon

Also, have you tried reinstalling both LAN and WiFi drivers?

i reinstalled the drivers and it's working now :)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.